Issues with 2.5.x kernels?


From: Martin Whitlock (martin.whitlock_at_possio.com)
Date: 2002-10-03 16:09:49 UTC



I've seen in the README that 2.5.x kernels should work with hostap, but I've experienced some problems. First of all, hostap_crypt_wep.o doesn't seem to load properly during init and I can't see why. If you modprobe it, it will load without problems... The strange thing is that I can (after a manual modprobe) set the card in master mode and connect clients to it and get pings through, regardless enc off or activated. But when I try to set the card in managed mode, it won't associate with an AP. I can't even get the macaddress of the AP.

I have a XScale pxa250 platform and we had to patch the driver due to a bug (errata 86) in the XScale's PCMCIA byte read (patch attached). After that we got it to work with a 2.4.18 kernel, but apparently not with the 2.5.30... Any id´┐Żas??

Thanks!
/Martin

[pxadmin_at_Linux /root]$uname -a
Linux Linux 2.5.30-rmk1-pxa1 #60 Tue Oct 1 14:05:01 CEST 2002 armv5tel unknown

<7>hostap_crypt: registered algorithm 'NULL'
hostap_cs: hostap_cs.c 0.0.0 2002-09-12 (SSH Communications Security Corp, Jouni
Malinen)
hostap_cs: (c) Jouni Malinen <jkmaline_at_cc.hut.fi>
<6>hostap_cs: hostap_cs.c 0.0.0 2002-09-12 (SSH Communications Security
Corp, Jo
uni Malinen)
<4>hostap_cs: (c) Jouni Malinen <jkmaline_at_cc.hut.fi>
hostap_cs: index 0x01: Vcc 3.3, irq 153, io 0xf7000000-0xf700003f
<7>hostap_cs: setting Vcc=33 (constant)
<7>hostap_cs: CS_EVENT_CARD_INSERTION
<7>prism2_config()
<7>hostap_cs: setting Vcc=33 (from config)
<7>Checking CFTABLE_ENTRY 0x01 (default 0x01)
<7>IO window settings: cfg->io.nwin=1 dflt.io.nwin=1
<7>io->flags = 0x0046, io.base=0x0000, len=64
<6>hostap_cs: index 0x01: Vcc 3.3, irq 153, io 0xf7000000-0xf700003f
hostap_cs: Registered netdevice wlan0
<6>hostap_cs: Registered netdevice wlan0
<7>prism2_hw_init()
<7>prism2_hw_config: initialized in 14786 iterations
wlan0: NIC: id=0x800c v1.0.0
<6>wlan0: NIC: id=0x800c v1.0.0

wlan0: PRI: id=0x15 v1.0.7
<6>wlan0: PRI: id=0x15 v1.0.7

wlan0: STA: id=0x1f v1.3.6
<6>wlan0: STA: id=0x1f v1.3.6
<7>wlan0: LinkStatus=2 (Disconnected)
<7>prism2: wlan0: operating mode changed 3 -> 2
<7>wlan0: LinkStatus=2 (Disconnected)
<7>wlan0: LinkStatus: BSSID=00:60:b3:69:6f:f5
<7>wlan0: LinkStatus=2 (Disconnected)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44
<7>wlan0: LinkStatus=2 (Disconnected)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44
wlan0: could not initialize WEP: load module hostap_crypt_wep.o
<4>wlan0: could not initialize WEP: load module hostap_crypt_wep.o
<7>wlan0: LinkStatus=2 (Disconnected)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44
<7>wlan0: prism2_open
<7>wlan0: prism2_close
<7>wlan0: prism2_open
<7>wlan0: prism2_close
<7>wlan0: LinkStatus=6 (Association failed)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44
<7>wlan0: LinkStatus=6 (Association failed)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44
<7>wlan0: LinkStatus=6 (Association failed)
<7>wlan0: LinkStatus: BSSID=44:44:44:44:44:44




This archive was generated by hypermail 2.1.4.